1996 corvettes got me scratching my head

grumpyvette

Administrator
Staff member
heres a bit of a head scratcher issue I have on my 1996 corvette I could use help with, some fuse or relay or sensor failed very recently,
and finding it is making me a bit nuts, the only trouble code that came up indicated the cooling fan relay was defective,
176.jpg

I changed all three cooling fan, relays, checked the fuses and fuse-able links,
but this failed to clear the problem, so Im obviously over looking something here gentlemen?
this will obviously be something I should have spotted easily but at this moment Im overlooking it!

Ive pulled codes several times and it shows no further codes.
DTC P1641 FC Relay 1 Control Circuit description is located in book #2 Page 6-599 of the service manual. For the cooling fan schematic, refer to Fan Control Circuits
Ive changed the engine temp sensor on the front and on the pass side head
and the trouble code is now gone but the
radiator fans still won,t turn on yet both fans test perfectly fine, and work if I just apply battery
all fuses test good
There are three cooling fan relays...And three fuses...Lets begin with the fuses...Fuse #2 (30A)= primary cooling fan...Fuse # 5 (40A)=secondary cooling fan...Both of these are under-hood. Fuse #29 (5A)=fan fuse...Feeds power to all three relays and is located inside...If all three fuses are good; Lets check the relays..All 3 relays receive power on a Pink wire multiple from fuse#29...Ground is fired to pull relay #2 and #3 on a Dark Blue wire from the PCM C1 pin# 10...Relay #1 receives ground from PCM C1 pin#10 on the Dark Green wire...
0900c1528008fca5.gif

fan1schematic_1995.jpg

313.jpg

coolantsenloc2a.jpg

coolantsenloc.jpg


https://www.ecklers.com/corvette/co...MIjKCGpePe3gIVgYzICh035w4jEAQYBCABEgK7ifD_BwE

coolta1.jpg

coolta2.jpg


https://www.rockauto.com/en/catalog...oling+system,temperature+sender+/+sensor,4748

1996ect.jpg

1996ect1.jpg

1996ect4.jpg


1711697-1__ra_p.jpg

https://www.autozone.com/repairguid...DIAGRAMS/WIRING-DIAGRAMS/_/P-0900c1528008fd94
1996ghj1.gif

1996ghj2.gif

1996ghj3.gif


the coolant temp sensor is located on the Pass side head between # 6 and 8 plugs.

Fan control varies by year.
As I recall.
'84 has temp switch for fan only ,no ECM control;
'85 has ECM control but temp switch acts as over ride backup direct to fan
'86- '89 as stated above
'90 onward ; both fans on ECM ; no temp switch.
And all have provision to turn the fans on with A/c on.


1996 and up corvettes are OBD2, which cannot use the paper clip trick.

Pro tip before starting - Label your relays Relay 1, Relay 2, and Relay 3 according to the wiring diagram (your first post) and what your physical relays represent. Even if its just a sticky note. Get it all straight and stick to the same annotation while you troubleshoot.

You'll need a multimeter than can measure DC voltage and continuity:

Remove all three relays so you're only dealing with the sockets

DC Voltage tests:
1. Confirm 12V between the socket for pin 85 and the negative battery terminal on all 3 relay sockets
2. Confirm 12v between the socket for pin 30 and the negative battery terminal on relay sockets 1 and 2

Continuity tests:
1. Confirm continuity with the end of the dark green wire and the socket for pin 86 for relay 1
2. Confirm continuity with the end of the dark blue wire and the socket for pin 86 for relay 2 AND relay 3.
3. Confirm continuity between the socket for pin 87 for relay 1 and side B of the left cooling fan connector
4. Confirm continuity between side A of the left cooling fan connector and side B of the right cooling fanconnector AND the socket for pin 87 for relay #2.
5. Confirm continuity between the socket for pin 87 for relay #3 and Negative Battery Terminal
6. Confirm continuity between side A of the right cooling connector and Negative Battery Terminal.

Do the steps in order and use the negative battery terminal for your connection when I specify to. Verifying at the negative battery terminal will ensure you're circuit is making a good connection to the chassis ground. If it doesn't make it all the way back to the battery, it's a crap ground and testing it my way will reveal the problem


fanwire99.jpg

THE DIAGRAM ABOVE HAS THE CORRECT WIRE COLORS
LT1chr.gif



Measured Value
Engine Coolant Temperature Sensor. 185 Ohms @ 210F, 3400 Ohms @ 68F, 7,500 Ohms @ 39 F.
Engine Oil Temperature Sensor. 185 Ohms @ 210 F, 3400 Ohms @ 68 F, 7,500 Ohms @39 F.
Oil Pressure Sender/Switch. 1 Ohms @ 0 PSI, 43 Ohms @ 30 PSI, 86 Ohms @ 60 PSI.
Fuel Quantity Sender. 0 Ohms @ Empty, 45 Ohms @ 1/2 Full, 90 Ohms @ Full.
MAT (Manifold Absolute Temperature Sensor). 185 Ohms @ 210 F, 3400 Ohms @ 70 F, 15,000 Ohms @ 40 F.
Outside Temperature Sensor. 4400 Ohms @ 60 F, 2200 Ohms @ 85 F.
In Car Temp Temperature Sensor. 4400 Ohms @ 60 F, 2200 Ohms @ 85 F.
MAF (Mass Air Flow) Sensor. .4 Volts @ idle, 5 Volts @ Full Throttle.
Oxygen (O2) Sensor. .1 Volt Lean Mixture, .9 Volt Rich Mixture.
TPS (Throttle Position Sensor). .54 Volts Idle, ~ 5 Volts Full Throttle.

Sensor Locations

Sensor


Location
Engine Coolant Temperature Sensor. Front of engine, below Throttle Body.
Engine Oil Temperature Sensor. Left rear of engine, just above the oil filter.
Oil Pressure Sender/Switch. Top, left hand rear of engine.
Fuel Quantity Sender. Top of fuel tank, beneath filler pipe escutcheon panel.
MAT (Manifold Absolute Temperature Sensor). Underside of manifold air plenum at rear.
Outside Temperature Sensor. Right side of engine, top right corner of radiator.
In Car Temp Temperature Sensor. Coupe: above left seat near interior courtesy light, Convertible: center of cargo compartment lid.
MAF (Mass Air Flow) Sensor. Front of engine ahead of throttle body.
Oxygen (O2) Sensor. Left side of engine, in exhaust pipe.
TPS (Throttle Position Sensor). Right side of throttle body at the front.


image_6238.jpg

this is the most consistently accurate I.R temp gun I've used for testing[/img]
42545.jpg

http://www.testequipmentdepot.com/extech/thermometers-and-humidity-meters/infrared-thermometers/high-temperature-infrared-thermometer-58to1832f-50to1-laser-pointer-42545.htm?utm_source=bing&utm_medium=cpc&utm_campaign=NEXT - Bing Shopping - Extech&utm_term=1100200223789&utm_content=All Extech Products
Manually spin the fan blade of the fan that doesn't work to
verify the fan motor isn't seized.

The fans use 3 relays mounted on the driver side
on the end of the radiator.

Primary cooling fan is an the driver side.
Secondary cooling fan is on the passenger side.

There are two modes of fan operation.
Both fans at half speed. 6 volts
Both fans at high speed. 12 volts.

There are two control lines the PCM grounds to
enable the fans.

PCM grounds the Dark Green wire for low speed.
Relay #1 is energized.

PCM grounds both the Dark Green wire and a Dark Blue
wire for high speed.
All three relays #1, #2 and #3 are energized.

Three fuses protect the circuits.
Fan fuse 5 amp located on passenger side of the dash.
This must be good because you say one fan does run.

Primary coolant fan 30 amp Maxifuse located under the hood.
Must be good if the driver side fan works.

Secondary coolant fan 40 amp Maxifuse located under the hood.

You can identify the relays by the color of the wires that
go to the relay sockets.

Relay #1 has the following colored wires.
Pink, Dark Green, Red and a Light blue wire.

Relay #2
Pink, Dark Blue, White and 2 Black wires.

Relay #3
Pink, Dark Blue, Red and a White wire.

To test the fans turn the ignition On.

Manually ground the control lines. Stick a nail
or probe, jumper wire etc... into the bottom of
the relay socket and ground the Dark Green wire.

Both fans should run at low speed.

Ground the Dark Green wire and the Dark Blue
wire and both fans should run at high speed.

Another method you can use is to carefully pry/remove
the plastic cover off of the relays. You can then
manually energize the relays by pushing down
on the metal plate.

Push down on the plate on #1 relay and both fans
should run at slow speed.

Push down the metal plate on all relays and both
fans should run at high speed.
95fan1.jpg

95fan2.jpg


READ THE LINKED INFO

http://garage.grumpysperformance.co...ette-fan-motor-quit-working.10559/#post-84177

http://garage.grumpysperformance.com/index.php?threads/1995-corvette-fan-motor-quit-working.10559/

REPLACING A C4 CORVETTE BATTERY VIDEO
http://www.youtube.com/watch?feature=pl ... 03-roWP2A#!
http://www.ebay.com/itm/1995-1996-C...diator-Hose-Set-LT1-LT4-engines-/121925824251

http://garage.grumpysperformance.co...rical-glitches-in-newer-cars.5492/#post-43932

https://corvetteparts.com/item/heat...o-lower-heater-core-lt1-lt4-engines-1993-1996
obviously the first step is labeling the cooling fan relays and getting out the shop manual looking over the testing info, and using the multi meter and checking fuses , grounds and reading up on the function, of each component, the charts above should help



fanwire99.jpg

my2centsm.png


http://members.shaw.ca/corvette86/Cooli ... ontrol.pdf


image_12926.jpg

http://www.harborfreight.com/5-in-1-dig ... 98674.html
having a wide assortment of different multi meter test leads available is a huge benefit while testing

the clip test leads that test thru a wires insulation without much damage are a big help

693Pred.jpg

bedtest1.jpg

bedtest2.jpg

bedtest3.jpg


RELATED REFERENCE THREADS
viewtopic.php?f=32&t=2697&p=18904&hilit=trouble+codes#p18904

viewtopic.php?f=80&t=728&p=18757&hilit=+sensor+locations#p18757

viewtopic.php?f=32&t=3954

viewtopic.php?f=57&t=149&hilit=sensor+locations

viewtopic.php?f=57&t=2538&p=21497&hilit=fans#p21497

viewtopic.php?f=36&t=3222&p=8575&hilit=testing+alternator#p8575

viewtopic.php?f=70&t=355&p=13196&hilit=+alternator#p13196
 
Last edited by a moderator:

Indycars

Administrator
Staff member

Sounds like a bad connection or broken wire, maybe connector C100.

Have you tested for voltage at the relay coils when temperature has risen high enough to turn on the fans?

 

mathd

solid fixture here in the forum
Take multimeter check fan grounds(negative probe to chassis and positive to fan ground(should be close to zero volt
then check if you have power at the fan
if not check for power at the relays and relay coil/trigger Should find it quickly.
 

grumpyvette

Administrator
Staff member
thanks guys Im going to go out and do more extensive testing with my multi meter , this is obviously something stupid Im overlooking, so keep the ideas flowing , its a big help.
remember , if you can,t figure out the way it works from the factory you always have options and can wire the fans yourself, but in most cases a meter and a shop manual and a bit of common sense and testing will locate your issues allowing you to correct and/or locate the problems source
http://www.racerpartswholesale.com/prod ... cessories2
why they bothered to have three relays control two fans that come on under various conditions rather than both fans controlled by simple thermal switches, so lets say the first comes on at 180f coolant temp and the second kicks in at lets say 210f is beyond my comprehension, the KISS PRINCIPAL is best (KEEP IT SIMPLE STUPID)
IM JUST CURIOUS?
how many of you gentlemen go to a computer, print out related wiring diagrams ,get out a multi meter and a shop manual and actually read the shop manual, and step thru the indicated testing procedures? check for voltage ohms resistance, loose connections, etc. and have actually used the shop manual, multi meter and printed wiring diagrams ans instructions to isolate and solve a problem on your car?
ITS NOT ALWAYS EASY BUT IT SURE BEATS RANDOM GUESS WORK EVERY DARN TIME

my2centsm.png

THE DIAGRAM ABOVE HAS THE CORRECT WIRE COLORS FOR THE 1996 CORVETTE

https://my.chevrolet.com/content/da...t/corvette/1996_chevrolet_corvette_owners.pdf

95fan2.jpg

mattt.png


https://www.corvettemods.com/C4-Cor...I0Y2Vwrnc3gIVFVmGCh0sjAeVEAQYAiABEgK4LPD_BwE#
95xfan.jpg


typicalrelayg.png

85vettecool1.jpg

BTW FAULTY GROUNDS, IN MANY CARS AND ESPECIALLY NEWER CORVETTES CAUSE MANY ELECTRICAL ISSUES SO IF YOU HAVE INTERMITTENT ELECTRICAL ISSUES CHECK THEM CAREFULLY
Grounds00021a.jpg


Here are some fairly simple things to check for various complaints:

~Fans are not operational at any time~


Check fan fuses in the underhood fuse/relay panel
Check fan relays (same location). Aside from getting out any electrical equipment to test the relay, you can swap it with another one (such as the fog lamp relay) and test for function. See if the relay works for the fog lamps and/or the swapped-in relay makes your fans work. Nearly all the relays in the panel are the same, except for maybe the ABS relay.
You can jumper two pins on the DLC that should cause the fans to come on. 1993-1994 cars with the 12 pin DLC can jumper pins A and B. On a 1993, that is the same way that you would retrieve trouble codes from the ecm. The 1994 won't give you any codes, but the fans will engage. 1995-1997 uses pins 5 and 6 on the 16 pin DLC to initiate what is called "field service enable mode". That will cause the fans to come on and operate most sensors for sanity checking. After placing the jumper on the correct pins, turn the key to ON (don't start). If the fans work after jumpering the DLC, your PCM is capable of operating the fans and all fan wiring/relays should be ok.
Deeper problems can be solved through testing and using the wiring schematic.


~Fans don't come on except when the a/c or SES is on~

~Temp gauge continues to rise with no automatic fan operation~


With a scan tool, check to see what temp the PCM is seeing from the sensor in the water pump. Make sure you are aware of the temps the fans come on (stated in the beginning of this article). If the temp it sees is incorrectly low, it won't know to turn the fans on. Another possibility is that the temp is really ok, but the gauge is reading wrong. That is why you need to use the scan tool to see and compare the readings. Info on testing wiring and sensor can be found here.
If that looks ok, then your PCM may have issues. You could always try resetting the PCM by pulling the PCM BAT fuse for about 30 seconds.


Other cooling issues

~Temps escalate with speed and fans are working~


Check for obstructions/debris in front of the a/c condensor (sometimes even between the condensor and radiator).
Make sure the air dam is on. Cars with low ground effects may need a special air dam to scoop up enough air for cooling.
Check the thermostat for proper operation. It can be tested in a pan of water, heated on a stove. It should begin to open at it's rated temperature and then open fully as it gets warmer.
While on the subject of thermostats, the LT1 reverse flow system uses a special, long thermostat that works together with the passages in the water pump to provide proper coolant routing. If you use an old SBC style thermostat, you run the risk of the system not operating with proper efficiency and it may overheat. Escalating temps can be caused by poor air or coolant flow.


~Generally running hot~


Examine system for any of the items mentioned above.
Check for air in the cooling system via the air bleed screws.
Check or replace the radiator cap (especially if you have heard lots of gurgling and overflow into the remote reservoir. The F-body system uses an 18 psi cap.
Check for any obvious leaks. If needed, rent a pressure tester that will allow you to pressurize the system while it is cool. This will allow you to see if it holds pressure and look for any leaks.


~Low coolant lamp on~


The low coolant sensor is a most common cause of complaint. If it gets dirty, it may cause the lamp to come on when the coolant level is actually ok. Sometimes it fails and no amount of cleaning will fix it. The sensor is only connected to the lamp on the dash. It does not report to the PCM and no DTC's will be set. Because of this, some people choose to simply unplug the sensor to get rid of the annoyance without having to fix it. Unplugging it will make the lamp go out, but you will have to monitor the coolant level yourself. As critical as the coolant is to the LT1, having it working makes sense.

If the light seems to come and go, make sure the level in the remote reservoir is proper. Normal operation of the cooling system often causes coolant from the radiator to overflow into the remote reservoir. As the engine cools down, the radiator creates a vacuum and pulls this coolant back into the radiator. The piping from the neck of the radiator to the reservoir must be air tight for this to occur. Since these cars are getting older, it is not uncommon to get a small leak in the pipe that goes under the battery. Acid wears away at the pipe until it makes a hole. Even a small hole is enough to cause problems. A telltale sign is a small amount of coolant under the right front of the car after it is parked a while. Usually, only taking out the battery will reveal where it is coming from, because it slowly drips on the splash panel underneath and may travel along to another area to drip off.

If the lamp is coming on for no apparent reason (you have verified coolant level is fine-that is, checked the level in a cold radiator and verified you have the proper level in the remote reservoir), you have a few choices:
Clean the sensor and try it again
Replace the sensor
Unplug the sensor (the low coolant lamp will stay off and there will be no monitoring of the coolant level)


Thermostats and cooling

The temp rating of the thermostat is merely at what temp it will begin to open and allow coolant flow. It is purely a mechanical, temperature reactive device and has no external control or monitoring. A frequent reason behind a lower temp thermostat is to be able to make use of more aggressive spark advance without the engine having any spark knock (detonation or pinging). Excessive spark knock is detrimental to the engine. Spark knock is also monitored by the computer and timing advance is pulled (retarded) by the computer. When timing is retarded, performance and power will decline.

There is a fine line between between enough spark advance for high performance and the penalties for too much. The engine temperature plays a role in that the coolant wicks away heat from the combustion chambers in the head. Higher overall engine temperature results in higher overal combustion chamber temperatures. Installing a lower temperature thermostat alone may actually decrease performance because a certain amount of heat is needed to burn the air/fuel mixture efficiently. If you see a decrease in gas mileage with a lower thermostat, alone, this may be the reason. The trick is to lower the temperatures but add enough timing to increase performance over what it was originally.

An often asked question is "Will my engine stay cooler with just a 160° thermostat?". The answer is yes, as long as there is good air flow across the radiator and the cooling system is working efficiently. Note that engine temps will still climb as they did before when you are stopped (as in traffic). However they may not rise as high, since you are starting out at a lower temperature than before. When you are moving again, it will be possible for the temps to lower more than what the 180° thermostat would previously allow. Cruising down the road, your engine should definitely stay cooler than before. Remember that the rated temperature of a thermostat is the temperature that it begins to open. While crusing on a moderate temperature day, an LT1 will generally run 10°-20° warmer than the thermostat temp rating. Make sure you use the correct, long LT1 thermostat (not an SBC thermostat) as described in the troubleshooting section above.

The thermostat only has control of opening temp to allow coolant flow, after that it does nothing but cause a predetermined amount of restriction in the flow. To make the most of the lower temperature thermostat, it should be accompanied by reprogramming of the fans, so that they will come on at a lower temperature. This will help to maintain a lower overall temperature in all driving conditions (especially when stopped in traffic). It is not mandatory that you do this and a 160º can be installed by itself with no other modification.

Something else to consider is that when the engine gets to ~220º (even before the stock fan ON temp of~226º) and you are at MAP loads of 70Kpa or more, the PCM begins to retard the timing. That is one reason why people feel their cars don't run well when they are hot. The GM folks built the retard into the spark tables because when the engine is hotter, there is more chance for spark knock. If you can keep the temperatures from getting up into that range, then you might feel more power when you need it.

Altering the fan ON temps can be done through reprogramming the computer or an aftermarket "fan switch" such as sold by SLP and JET . Manual fan switches can also be wired up to operate the fan relays so that the fans can be operated at any given time the driver wants (like in staging lanes). There are explanations on how to wire the manual switch up on the 'net and there are even a couple of wiring diagrams in the electrical section of my Tech Page. If you look at the fan schematics, you can probably see that there can be several solutions to operating the fans manually (my preference being to control the existing relays)
.
CTS_diagnosticsl.gif

LOW READING
CTS_diagnosticsh.gif

HIGH READING

the earlier c4 corvettes had a simplier wire diagram for fans
1987cool.png



heres a couple related threads with links and sub-links that will provide you a great deal of related and useful info related too cooling your corvette
http://garage.grumpysperformance.com/index.php?threads/cooling-off-that-c4-corvette.3954/
http://garage.grumpysperformance.co...t-of-logic-to-locate-a-problems-source.14297/
http://garage.grumpysperformance.co...-air-conditioner-on-cooling.12232/#post-59597
http://garage.grumpysperformance.co...e-out-intermittent-fan-issue.9229/#post-33215
http://garage.grumpysperformance.co...es-got-me-scratching-my-head.7499/#post-25445
http://garage.grumpysperformance.com/index.php?threads/cooling-issue.13389/
http://garage.grumpysperformance.com/index.php?threads/1995-corvette-fan-motor-quit-working.10559/
http://garage.grumpysperformance.com/index.php?threads/c4-c5-corvette-trouble-codes.2697/#post-69239
http://garage.grumpysperformance.co...lay-switch-locations-and-info.728/#post-66935


this looks interesting with a discount coupon its discounted to about $169.99 until 4/30/18 plus $49.99 for a two year 100% warranty

http://garage.grumpysperformance.co...pro-scanner-harbor-freight-zurich-zr13.14833/





digitalsavings_08.png

https://www.harborfreight.com/catalogsearch/result/index/?dir=asc&order=EAScore,f,EAFeatured+Weight,f,Sale+Rank,f&q=zr13
zr13sc.png

zr13sc1.png


if you purchase a ZR13 auto code scanner, from HF,
you need this info
DOWN-LOAD AND PRINT IT OUT!


https://manuals.harborfreight.com/manuals/63000-63999/Q63806.pdf

https://manuals.harborfreight.com/manuals/63000-63999/63806.pdf



 
Last edited by a moderator:

grumpyvette

Administrator
Staff member
well after a good deal of repeated testing it looks like its an intermittent connection in the 5 pin relay pig tail assembly that was causing my cooling issues

http://www.rockauto.com/catalog/moreinf ... cc=1041398

http://www.parts123.com/0000050f/244508 ... 244508.htm

you really need to purchase a multi meter and a SHOP MANUAL and look thru the schematics
without testing theres almost no way to locate the source of your problem,, testing will tell you

http://www.helminc.com/helm

1996_Corvette.jpg


http://www.harborfreight.com/5-in-1-dig ... 98674.html
heres a cheap yet effective multi meter
image_6238.jpg

if you work around older cars for awhile your sure to notice a great many problems can be traced back to faulty, corroded or broken electrical connections, sockets and connectors or fuses ans wiring that need to be repaired or replaced, especially in moist areas, and in many cases youll be far ahead to just buy a new connector and carefully solder it in and use shrink tubing over the splice

automotive electrical connectors and related info

http://repairconnector.com/

viewtopic.php?f=70&t=1443&p=28051&hilit=shrink#p28051

http://www.connectorsupply.com/catalog/ ... 6ae598085b

http://www.bing.com/images/search?q=Wir ... tedIndex=0

http://www.rjminjectiontech.com/collect ... connectors

http://paceperformance.com/c-142454-ele ... tails.html

viewtopic.php?f=50&t=3110&p=8302&hilit=electrical+connectors#p8302

viewtopic.php?f=36&t=3439&p=19529&hilit=owner+wiring#p19529

http://www.rockauto.com/catalog/x,carco ... BConnector


http://www.ecklers.com/search.asp?actio ... chHistory=

http://www.eficonnection.com/eficonnect ... eType.aspx

http://www.suresealconnections.com/

http://www.repairconnector.com/

http://www.waytekwire.com/automotive-connectors.htm

http://www.rowand.net/Shop/Tech/Automot ... ectors.htm

http://www.vette2vette.com/

http://www.mamotorworks.com/corvette-3-408-1079.html
RELATED THREADS YOULL NEED IF TRACKING A SIMILAR ISSUE


viewtopic.php?f=70&t=3504&p=33365&hilit=electrical+connectors#p33365

viewtopic.php?f=70&t=3504

viewtopic.php?f=50&t=609&p=26934&hilit=electrical+connectors#p26934

viewtopic.php?f=70&t=986&p=7010&hilit=electrical+connectors#p7010

viewtopic.php?f=80&t=728&p=1243&hilit=electrical+connectors#p1243

viewtopic.php?f=48&t=318&p=385&hilit=electrical+connectors#p385

viewtopic.php?f=87&t=5492&p=18411&hilit=electrical+connectors#p18411

viewtopic.php?f=70&t=4309&p=11361&hilit=electrical+connectors#p11361

viewtopic.php?f=36&t=3222&p=8575&hilit=electrical+connectors#p8575

viewtopic.php?f=32&t=2697&p=8434&hilit=electrical+connectors#p8434

viewtopic.php?f=50&t=3110&p=8302&hilit=electrical+connectors#p8302
 

Grumpy

The Grumpy Grease Monkey mechanical engineer.
Staff member

ok guys, one factor I,m dealling with is that the battery died in my corvette,
obviously due to my infrequent use, or not driving the corvette more than occasionally, and intermittently.
yes I have a batter minder on the car, but I found that the battery trickle charger failed,
what battery do you gentlemen consider the best value in a corvette battery
1996baty.jpg

http://garage.grumpysperformance.com/index.php?threads/battery-charger-for-the-shop.928/#post-55812
well I eventually dropped by walmart as the battery I had ,
previously last four 4.5 years and just bought a second 75n premium battery
at roughly $95 plus the old battery trade in its not a bad value

https://www.walmart.com/ip/EverStart-Maxx-Lead-Acid-Automotive-Battery-Group-Size-75N/16782711
 
Last edited:

Grumpy

The Grumpy Grease Monkey mechanical engineer.
Staff member
BTW if youve replaced all the related fuses and the three fan relays, and your still having intermittent cooling fan start issues check that
G117 COOLING FAN GROUND CAREFULLY, (left front frame)
I find that it is rather common to have corrosion issues on that ground location.
(the G104, G105, G106, G107 , on the back of the drivers side cylinder head and bell housing can and do come loose or get forgotten on some engine repairs so check those of the dash or gauges etc are intermittent or not functioning


my2centsm.png

95fan2.jpg

Grounds00021a.jpg


  • Lead color code

  • Black: Coil supply

  • White: Coil supply

  • Red: SPDT normally open

  • Blue: SPDT common

  • Yellow: SPDT normally closed

-30 = constant [positive (+)] power (usually wired directly to car battery)
-85 = coil ground (wired to the negative (-) battery terminal or any grounded metal panel in the car)
-86 = coil power (wired to the control source. could be a switch, or it could be the car's IGN or ACC circuit.)
-87 = switched [positive (+)] power output. (when the relay coil is powered, lead/pin 87 is connected to lead/pin 30)
-87a = [on 5 lead/pin relays only] this lead/pin is connected to lead/pin 30 when the coil is NOT powered.


relaywire.jpg
 
Last edited:
Top